Upgrade the Unity plugin from 2.8.49 to 2.8.49.1

No special steps are required to upgrade to 2.8.49.1.

Upgrade the Unity plugin from 2.8.48 to 2.8.49

For targetSdkVersion 28+ Network Security Configuration file was added to Appodeal's AndroidManifest.xml.

Upgrade the Unity plugin from 2.8.19 to 2.8.48

  1. Update Google Play Services from 10.2.1 to 15.0.0 or higher.
  2. If you use Play Services version 17 and up, add <meta-data> tag to AndroidMmanifest file:

    <meta-data
    	android:name="com.google.android.gms.ads.APPLICATION_ID"
    	android:value="[ADMOB_APP_ID]"/>
  3. MREC is now deprecated.

  4. For apps that are targeting to API level 28 (Android 9.0) or above, make sure to specify additional library declaration Apache HTTP Legacy. Add the code below to the <application> section of AndroidManifest.xml.

    <uses-library
    	android:name="org.apache.http.legacy"
    	android:required="false" />
  5. Add consent value to Appodeal.initialize (Add GDPR support).

  6. New methods were added:

    • Appodeal.setExtraData;

    • Appodeal.getPredictedEcpm.

  7. Now you can track Ads expiration with new onExpired callbacks.