Upgrade the Unity plugin from 2.x.x to 3.0.0 UPM

  1. Remove previous version of Appodeal Unity Plugin ( Appodeal -> Remove plugin at the top menu bar)
  2. To install 3.0 Appodeal Unity Plugin go to Window -> Package Manager -> "+" -> Add package from git URL at the top menu bar, insert the link from doc and click Add
  3.  Whether you want to get our demo as a reference head to Window -> Package Manager -> Appodeal Stack -> Appodeal -> Samples and click Import.
  4.  Look through the get started section of our doc to make sure your Unity project is set up in a proper way.
  5.  Use  using AppodealStack.Monetization.Api; instead of using AppodealAds.Unity.Api;
  6.  Use  using AppodealStack.Monetization.Common; instead of using AppodealAds.Unity.Common;
  7.  Use using AppodealStack.ConsentManagement.Api; and using AppodealStack.ConsentManagement.Common; instead of using ConsentManager.Common;
  8.  Capitalize all methods of Appodeal Unity Plugin (including callbacks)
  9.  Use public void OnConsentFormError(IConsentManagerException exception) instead of public void onConsentFormError(ConsentManagerException exception)
  10.  Use public void OnConsentFormClosed(IConsent consent) instead of public void onConsentFormClosed(Consent consent)
  11.  Use public void OnConsentInfoUpdated(IConsent consent) instead of public void onConsentInfoUpdated(Consent consent)
  12.  Use public void OnFailedToUpdateConsentInfo(IConsentManagerException error) instead of public void onFailedToUpdateConsentInfo(ConsentManagerException error)
  13.  Implement new callback methods for banner and mrec ad types public void OnBannerShowFailed() {} and public void OnMrecShowFailed() {} (only if you use them)
  14.  Use IConsent interfaces everywhere you used Consent objects.
  15.  Use AppodealAdType.Type constants instead of Appodeal.ADTYPE for all methods except Appodeal.Show() (use AppodealShowStyle.Style for it). For example, Appodeal.Cache(AppodealAdType.RewardedVideo)Appodeal.Show(AppodealShowStyle.BannerBottom)
  16.  Use SetFeatureIds() method of Vendor.Builder class instead of setFeatureId()
  17.  Use ConsentForm.GetInstance(this); instead of new ConsentForm.Builder().withListener(this).build();
  18.  Use Show() method of ConsentForm object instead of showAsActivity() and showAsDialog() methods
  19.  Use values of AppodealLogLevel enum instead of Appodeal.LogLevel. For example, ApppodealLogLevel.Verbose
  20.  Use Appodeal.SetCustomFilter(PredefinedKeys.UserAge, 18); instead of Appodeal.setUserAge(1);
  21.  Use Appodeal.SetCustomFilter(PredefinedKeys.UserGender, (int) AppodealUserGender.Male); instead of Appodeal.setUserGender(UserSettings.Gender.OTHER);
  22.  Use Appodeal.SetLocationTracking(false); instead of Appodeal.disableLocationPermissionCheck();
  23.  Remove Appodeal.setBannerBackground(); method from your code if it was used before, as it's no longer exists in Android and iOS Appodeal SDKs
  24.  Consider removing Appodeal.setSharedAdsInstanceAcrossActivities()  method as it is obsoleted and will be removed from the next release.
  25.  Use Appodeal.SetCustomFilter() methods instead of Appodeal.setSegmentFilter()
  26.  Use Appodeal.Initialize(string appKey, int adTypes, IAppodealInitializationListener listener) method instead of your previous implementation.
  27.  Use constants of AppodealViewPosition class to position banner and mrec views. For example, Appodeal.ShowBannerView(AppodealViewPosition.VerticalBottom, AppodealViewPosition.HorizontalCenter, "default"); (You still can use custom positioning as before)

Upgrade the Unity plugin to 2.15.4

Before importing Appodeal Unity Plugin 2.15.4 you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.15.3

Before importing Appodeal Unity Plugin 2.15.3 you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.15.2

Before importing Appodeal Unity Plugin 2.15.2, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.15.1

Before importing Appodeal Unity Plugin 2.15.1, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.15.0

Before importing Appodeal Unity Plugin 2.15.0, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.14.5

Before importing Appodeal Unity Plugin 2.14.5, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.14.4

Before importing Appodeal Unity Plugin 2.14.4, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.14.3

Before importing Appodeal Unity Plugin 2.14.3, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.14.2

Before importing Appodeal Unity Plugin 2.14.2, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.14.1

Before importing Appodeal Unity Plugin 2.14.1, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.14.0-Beta

Before importing Appodeal Unity Plugin 2.14.0-Beta, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.13.1

Before importing Appodeal Unity Plugin 2.13.1, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.13.0-Beta

Before importing Appodeal Unity Plugin 2.13.0-Beta, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.12.1

Before importing Appodeal Unity Plugin 2.12.1, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.12.0-Beta

Before importing Appodeal Unity Plugin 2.12.0, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.11.2

Before importing Appodeal Unity Plugin 2.11.2, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin to 2.11.1

You can update Appodeal Unity Plugin via Appodeal SDK Manager tool in Unity menu bar. (Appodeal > Manage Appodeal SDK)

Upgrade the Unity plugin to 2.11.0

Before importing Appodeal Unity Plugin 2.11.0-Beta, you need to remove the previous version using the internal of plugin option Appodeal>Remove plugin.

Upgrade the Unity plugin from 2.10.6-Beta to 2.10.7

You can update Appodeal Unity Plugin via Appodeal SDK Manager tool in Unity menu bar. (Appodeal > Manage Appodeal SDK)

Upgrade the Unity plugin from 2.10.5-Beta to 2.10.6-Beta

You can update Appodeal Unity Plugin via Appodeal SDK Manager tool in Unity menu bar. (Appodeal > Manage Appodeal SDK)

Upgrade the Unity plugin from 2.10.4-Beta to 2.10.5-Beta

You can update Appodeal Unity Plugin via Appodeal SDK Manager tool in Unity menu bar. (Appodeal > Manage Appodeal SDK)

Upgrade the Unity plugin from 2.10.3-Beta to 2.10.4-Beta

Before importing Appodeal Unity Plugin 2.10.4-Beta, you need to remove the previous version using the internal of plugin option Appodeal> Remove plugin.

Upgrade the Unity plugin from 2.10.2-Beta to 2.10.3-Beta

Before importing Appodeal Unity Plugin 2.10.3-Beta, you need to remove the previous version using the internal of plugin option Appodeal> Remove plugin.

Upgrade the Unity plugin from 2.10.1-Beta to 2.10.2-Beta

Before importing Appodeal Unity Plugin 2.10.2-Beta, you need to remove the previous version using the internal of plugin option Appodeal> Remove plugin.

Upgrade the Unity plugin from 2.10.0-Beta to 2.10.1-Beta

Before importing Appodeal Unity Plugin 2.10.1-Beta, you need to remove the previous version using the internal of plugin option Appodeal> Remove plugin.

Upgrade the Unity plugin from 2.9.3 to 2.10.0

Before importing Appodeal Unity Plugin 2.10.0, you need to remove the previous version using the internal of plugin option Appodeal> Remove plugin.

Upgrade the Unity plugin from 2.9.2 to 2.9.3

No special steps are required to upgrade to 2.9.3.

Upgrade the Unity plugin from 2.9.1 to 2.9.2

No special steps are required to upgrade to 2.9.2.

Upgrade the Unity plugin from 2.8.64 to 2.9.1

Before importing Appodeal Unity Plugin 2.9.1, you need to remove the previous version using the internal of plugin option Appodeal> Remove plugin.

Upgrade the Unity plugin from 2.8.63 to 2.8.64

No special steps are required to upgrade to 2.8.64.

Upgrade the Unity plugin from 2.8.62 to 2.8.63

No special steps are required to upgrade to 2.8.63.

Upgrade the Unity plugin from 2.8.61 to 2.8.62

You can use the new  updateConsent(boolean hasConsent)  method to provide the GDPR user consent for ad networks in Appodeal SDK anywhere of your application. Appodeal SDK don't keep the GDPR user consent between session, that means you should provide consent every time, otherwise, Appodeal SDK uses default or server value. By default consent value is  true .

Upgrade the Unity plugin from 2.8.60 to 2.8.61

No special steps are required to upgrade to 2.8.61.

Upgrade the Unity plugin from 2.8.59 to 2.8.60

No special steps are required to upgrade to 2.8.60.

Upgrade the Unity plugin from 2.8.58 to 2.8.59

No special steps are required to upgrade to 2.8.59.

Upgrade the Unity plugin from 2.8.57 to 2.8.58

No special steps are required to upgrade to 2.8.58.

Upgrade the Unity plugin from 2.8.56 to 2.8.57

No special steps are required to upgrade to 2.8.57.

Upgrade the Unity plugin from 2.8.55 to 2.8.56

No special steps are required to upgrade to 2.8.56.

Upgrade the Unity plugin from 2.8.54 to 2.8.55

No special steps are required to upgrade to 2.8.55.

Upgrade the Unity plugin from 2.8.53 to 2.8.54

No special steps are required to upgrade to 2.8.54.

Upgrade the Unity plugin from 2.8.52 to 2.8.53

No special steps are required to upgrade to 2.8.53.

Upgrade the Unity plugin from 2.8.51 to 2.8.52

No special steps are required to upgrade to 2.8.52.

Upgrade the Unity plugin from 2.8.50 to 2.8.51

No special steps are required to upgrade to 2.8.51.

Upgrade the Unity plugin from 2.8.49.1 to 2.8.50

No special steps are required to upgrade to 2.8.50.