Upgrade the iOS SDK from 2.4.9 to 2.4.10

Integration via pods

  1. Update your pod file: deployment target remains the same as for 2.4.9 ( it should be 9.0) and pod version should be changed from '2.4.9' to '2.4.10'.
  2. If you use only some parts of Appodeal SDK (ad types), pod file updating will be the same. For example: from "pod 'Appodeal/Banner', '2.4.9' " to "pod 'Appodeal/Banner', '2.4.10' " and deployment target stays the same as for 2.4.9 (it should be 9.0).

Manual integration

Manual integration stays the same as in 2.4.9. All libraries remain the same.

Upgrade the iOS SDK from 2.4.8 to 2.4.9

Integration via pods

  1. Update your pod file: deployment target can't be lower than 9.0 ("platform: ios, '9.0' ") and pod version should be changed from '2.4.8' to '2.4.9'.
  2. If you use only some parts of Appodeal SDK (ad types), pod file updating will be the same. For example: from "pod 'Appodeal/Banner', '2.4.8' " to "pod 'Appodeal/Banner', '2.4.9' " and update deployment target from 8.0 to 9.0.

Manual integration

  1. If you used manual integration in 2.4.8, your "Link Binary WIth Libraries" table in "Build Phases" page should look as follows.
Apple frameworks
AdSupportCoreTextMobileCoreServices
AudioToolboxEventKitUIQuartzCore
AVFoundationEventKitSafariServices
CFNetworkGLKitSecurity
CoreBluetoothImageIOSocial
CoreFoundationJavaScriptCoreStoreKit
CoreGraphicslibc++SystemConfiguration
CoreImagelibsqlite3.tbdTwitter
CoreLocationlibxml2.2.tbdUIKit
CoreMedialibz.tbdWatchConnectivity
CoreMotionMediaPlayerWebKit
CoreTelephonyMessageUI

In 2.4.9 you should add VideoToolbox to Libraries. All other libraries in the table should remain unchanged.